Migrate Magento 1 to Magento 2 - Ultimate Guide (V3)

14 ratings | 13398 views


Migrate Magento 1 to Magento 2 - Ultimate Guide (V3)

[Jun 28, 2018] UB Data Migration Pro is fully compatible with the latest Magento 2.2.5. [Sept 15, 2017 Update] We've introduced an absolutely refreshed Dashboard User Interface with easier navigation. All 8 pre-migration setting steps work very similar to how it has in the past, but it’s much quicker to control the whole migration process. What will be the best way to move your large-scale Magento 1 data to a Magento 2 shop? Our latest UB Data Migration Pro V3.0.0 (V3) will make your data migration process a lot easier. The version V3 is a complete overhaul, compared to its older sibling: - Completely revamped codebase to optimise for large-scale data migration - (New) Support delta migration - (New) Support PHP Memcached to improve performance - (New) Support Command-line Interface (CLI) for migration steps - (Fine-tuning) Allows migration process to be proceeded multiple times Check out UB Data Migration Pro and UB Data Migration Lite at: We had chance to use the UB Data Migration Pro V3 to migrate 382,047 customer entities successfully to Magento 2. Take a look at this interview () to see for yourself. Thanks for taking the time to view and we trust that your database migration will go smoothly, However if something happens then don’t hesitate to comment or contact us and we’ll love to be of help.

Comments to the video: Migrate Magento 1 to Magento 2 - Ultimate Guide (V3)

Botas Cuadra 6 months ago
Im trying to use the lite version to test it and it does not recognize any data from the 1.9.x version. I tried migrating to ver 2.0.2 and 2.2.5 and neither worked. It shows that I only have the root category and no products, so it won't migrate any data.
ubertheme 6 months ago
Hi Botas Cuadra, We wonder which Lite version you're using. We have an old script on Github, however we no longer maintain this outdated version, and have replaced it with a newer Pro version here - We also have another Lite version at Ubertheme, however it is based on an outdated codebase as well. This Lite version has a few drawbacks: - It is available for Magento 2.0.7 only, and your M2 must be a fresh instance - It does not support NGINX server - It uses old codebase and comes with limited feature set, which might cause unexpected issue So, we highly recommend you consider moving forward with our Pro version. It will definitely save you pretty much time. Regards, Ubertheme team
Jeevan Shrestha 6 months ago
What happens if I run migration multiple times? We have a big magento 1 website. we are planning to upgrade to magento 2. We have new products added to our website everyday and new customers signing up. So is it possible to sync the magento 1 and magento 2 database by running the migration every day until we phase out magento 1.
Agustina Diaz de Tuesta 1 year ago
Hi! I'm trying to install it via composer, and I get the following error Package ubertheme/module-ubdatamigration at version has a PHP requirement incompatible with your PHP version (7.1.11). Don't you have any version compatible with php 7.1.11?? thanks!
Agustina Diaz de Tuesta 1 year ago
Thanks! I'm gonna try with that script.
ubertheme 1 year ago
Hi Agustina Diaz de Tuesta,  It seems you used our old script on Github which uses an outdated codebase. We discontinued this one and replaced with a newer Pro version here:  The Pro version is fully compatible with the latest Magento 2.2.2, supports PHP 7.0+, plus many new features and improvements, such as delta migration, CLI etc. PS. You might want to take a look at this Magento 2 data migration faqs -  with a few questions you might concern during the migration process. Regards, Ubertheme team
Rodel Dagohoy 1 year ago
Hi try your migration tools but nothing happen when i click UB migration No migration Setting , I use Magento 2.0.7 for testing only Server Ubuntu 16+ / Serverpilot / 7.0+ php
ubertheme 1 year ago
Hi El Capitan, We wonder which version you're using? We have an old script via Github that we no longer maintain. If you use our UB Data Migration Lite, please note that the Lite version is not ready for NGINX server yet. For better help, please submit a ticket on our forum helpdesk here - , we will follow up further with you. Regards, Ubertheme team
Reece Vaughan 2 years ago
Hey guys, I'm using plesk and our main site (1.9) uses php 5.5 however I've installed php 7 for the m2 installation and anytime I open putty to run the commands as shown in the video its throwing out php parse errors, assuming because its using php 5.5, any way to force php 7?
ubertheme 2 years ago
Hi Reece, Glad that you find a workaround at your end. Actually, our Pro version comes with various brand new features like Delta Migration, Command-line Interface etc., which are not available in our old script. Further the whole code base in Pro version was revamped to optimise for large database migration, plus with ongoing bug fixes (This took us huge resources to develop our migration tool to this stage). Anyway, please reach us anytime if you have any question. We will try to provide help as far as we can. Regards, Ubertheme team.
Reece Vaughan 2 years ago
Hey guys, managed to sort it out by using export PATH=/opt/plesk/php/7.0/bin:$PATH (in my case) it actually fixed the problem and I got to the cut off where you're forced to pay for the pro version, decided to use the official Magento export tool as it was a little disheartening cutting me off mid way through and forcing me to upgrade to a tool for support
ubertheme 2 years ago
Hi Reece, We wonder if you have sorted it out at your end. Please take a look at this thread to learn about tweak to change PHP CLI version in plesk: Hope that helps. PS. Please submit a ticket via our helpdesk () in case you have a question. We will provide you faster response. Regards, Ubertheme team
Juliano Vargas 2 years ago
Hi ubertheme. UB Data Migration tool would be very useful for the company I am working on. I just have one question. Does UB data migration tool migrate all cms pages and cms blocks? Thank's ubertheme.
ubertheme 2 years ago
Hi Juliano, Our migration tool migrates the core Magento database only. For the theme or 3rd party extensions, the shortest way is to get their M2 version from the theme / extension provider. Regards, Ubertheme team
eWonderWorld 2 years ago
@ubertheme I downloaded the Lite version to test the entire process on Windows via XAMPP. I managed to get it installed, but once I click Next on Step 1 (to go to Step 2), it gives me an error that says the following: The table core_website for active record class Mage1Website cannot be found in the database. I couldn't find any information about it on your website. I did a google search, but no solution was found, and it looks like I wasn't the only one that faced this issue. Can you provide some answers please? Thank you.
ubertheme 2 years ago
Hi eWonderWorld, Actually the Lite version is mainly for testing purpose, and it is still based on the old V2 version. The V3 we mentioned earlier is a complete overhaul that comes with brand new features like delta migration, command-line interface support etc., One of our users has used the V3 to migrate successfully 230,000 products to Magento 2, please take a look to see for yourself - PS. If you decide to move forward with our V3 version, please take advantage of our Xmas offer via (24 hours left) Sincerely, Ubertheme team
eWonderWorld 2 years ago
Hi ubertheme, Thank you for your support. I didn't realize it was only compatible with 2.0.7. I was trying to do the migration to 2.1.x. I guess that's probably why it didn't work out. Anyways, thanks again! Happy New Years. Regards, eWonderWorld
ubertheme 2 years ago
Hi eWonderWorld, We're sorry for getting back to you a bit late. Please submit a ticket via our Helpdesk, our team will have a closer look into your case - . PS. At present, our Lite version is only available for Magento 2.0.7 though. Regards, Ubertheme team